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Smart View Training Guide

This training guide has been created to enable users to take advantage of the data and analysis functions available
in C-BIG through the Smart View add-in. It is encouraged that users follow along with the steps and replicate what
is presented in the manual. Should any questions come up during your review of the information, please feel free
to contact APB’s Hyperion Planning Analyst, Cathy Son at cson@ponet.ucla.edu or x53833.

Smart View Overview
e Microsoft Office add-in for Oracle Hyperion Planning applications
e Allows users to input data through templates created for C-BIG
e Provides ad-hoc query capability to users in a familiar Excel environment
o Allows users to dynamically access the live data and develop their own queries
e Allows users to pull CBIG reports to manipulate in Excel

Installing Smart View
To begin, first install Smart View (with the help of your IT team, if needed).

1. To download, go to the APB C-BIG webpage and click the Download Smart View! link.

2. Download and install - be sure to right-click the .exe file and select Run as Administrator when
installing.

3. Open Excel and verify that the Smart View tab is there.

If there are other Excel Add-ins installed, you may need to disable them for
Smart View to run properly (i.e. Acrobat PDFMaker Office COM Addin). Go

& to File > Options > Add-Ins > Excel Add-ins > Go... and uncheck add-ins you
would like to disable (see image below).

If Smart View is installed, but does not appear in Excel, make sure Oracle
Smart View for Office is checked under both Excel Add-ins and COM Add-
ins.


mailto:cson@ponet.ucla.edu
http://www.apb.ucla.edu/resource-management/c-big

Excel Options

Setting Up Smart View Connection

1. After the installation of Smart View is complete, launch Microsoft Excel.
2. Select Smart View from the menu.

3.

[x -

-

FILE HOME INSERT

=

=

Panel | Connections

-

Start

) Undo

& Redo

In the Smart View Ribbon, select Options:

PAGE LAYOUT FORMULAS DATA VIEW
Copy = 9= ¢ Help -~
. @@ O
Paste & Sheet Info
Refresh | Submit | Options
Functions ~ . D E El More ~
ata
Edit Data General

4, Within the Options window, select Advanced.

5.

https://finbud.it.ucla.edu/workspace/SmartViewProviders

SMART VIEW

In the Shared Connections URL section, copy the entire URL below and paste into the box:

G | . . .
eners E'B View and manage Microsoft Office Add-ins.
Formulas
Proofing Add-ins
Save Name Location Type &
Language Active Application Add-ins
Acrobat PDFMaker Office COM Addin C\.5\PDFMaker\Office\PDFMOfficeAddindll  COM Add-in
Advanced Oracle Smart View for Office C\Oracle\SmartView\bin\HsTbarxla Excel Add-in
Customize Ribbon Oracle Smart View for Office CA\Oracle\SmartView\bin\HsAddin.dll COM Add-in
Quick Access Toolbar Inactive Application Add-ins
Add-Ins Analysis ToolPak C\,..Office15\Library\Analysis\ANALYS32.XLL  Excel Add-in
Analysis ToolPak - VBA C\..fice15\Librany\Analysis\ATPVBAEN.XLAM  Excel Add-in he
Trust Center Add-in: Acrobat PDFMaker Office COM Addin
Publisher: Adobe Systems, Incorporated
Compatibility: MNo compatibility information available
Location: C\Program Files (x86)\Adobe\Acrobat 2015\PDFMaker\Office'\PDFMOfficeAddin.dll
Description: Acrobat PDFMaker Office COM Addin
Manage: |Excel Add-ins A4 Go..



https://finbud.it.ucla.edu/workspace/SmartViewProviders
http://cbig.ais.ucla.edu:19000/workspace/SmartViewProviders
http://cbig.ais.ucla.edu:19000/workspace/SmartViewProviders
http://cbig.ais.ucla.edu:19000/workspace/SmartViewProviders

Options ¥

b,

Member Options H & Change global Smart View options. ~

Data Options e
General .

Advanced Shared Connections URL: | https: /{finbud.it.uda. edu: 19000,.'work5pace,.'5m;| - |

. MNumber of Undo Actions =

Formatting = I=]
Number of Most Recently Used items

Cell Styles %

Delete All MRU Items

6. Click OK.

If you receive the following message when trying to save your Options,
Note! . .
l please create a log file by following the steps below:

Oracle Smart View for Office

o bk

'Q Failed to open message log file. :

OK

1. In Options > Advanced, check Route Messages to File option and click on the elipses icon to search for a file
location:



Options

Member Options
Data Options
Advanced
Formatting

Cell Styles

Extensions

Change global Smart View options.

General (i)

Shared Connections URL: http:Hchig.ais.ucla.edu:IQDDwaorkspacemeE| - |

Number of Undo Actions
Mumber of Most Recently Used items
Delete All MRU kems

Logging (i)

Log Message Display |Errors | - |

[+] Route Messages to File | |

[ ] clear Log File on Next Launch
[ ] show Diagnostics Group on Smart View Ribbon
Display (i)
Language English | - |

[ ] pisplay Smart View Shortcut Menus Only

[ ] pisable Smart View in Outlook

[+] Enable Ribbon Context Changing

[+] Disable options that are not valid for the active connection

[ ] isplay Drill-Through Report ToolTips

[ ] show Progress Information After (seconds) | :
Compatibility (i)
[+] Reduce Excel File Size

lmpro\.re Metadata Storage

[ ] Refresh Selected Functions and their dependents

Mode (i)

Use Double-click for Operations

2. At afolder/location of your choice, right-click and select New > Text Document.




Open

Contact

@ * 1 | <« Oracle » SmartView v | & | Search SmartView »p
Organize * New folder = [l @
” MName Date modified Type
& This PC
| extensions 8/3/2016 9:27 AM File folder
I Desktop
I Documents View >
Iy Downloads Sort by >
¥ Music Group by »
& Pictures Refresh
B Videos Paste
% Local Disk (C) Paste shortcut
& Undo Rename Ctrl+Z
¥ Share with r
F New *| | Folder
=4 Properties #] shortcut
v £ 2
¥ Microsoft Access Database
File name: W Bitmap image
(2=

Microsoft Word Document
Journal Document
Microsoft PowerPoint Presentation

Microsoft Publisher Document

Text Document P

Microsoft Excel Worksheet
Compressed (zipped) Folder

e E=

3. Name your document “SmartViewlLog.log” and select Open.
4. Uncheck the Route Messages to File option and click OK > Save as Default Options:



Options

Member Options
Data Options
Advanced
Formatting

Cell Styles

Extensions

Change global Smart View options.

General

Shared Connections URL:
Number of Undo Actions

Number of Most Recently Used items
Delete All MRU ems

Logging

Log Message Display

[|Route Messages to File

Clear Log File on Next Launch

[ ] show Diagnostics Group on Smart View Ribbon

Display

Language

|:| Display Smart View Shortcut Menus Only
[ | pisable Smart View in Outlook

Enable Ribbon Context Changing

http://cbig.ais.ucla.edu:19000/workspace/Smz

e |

|Err0rs

|v|

| C:\Usersh

\AppData\Roaming\Oracle\SmartVi e| .

English

Disable options that are not valid for the active connection

[ ] pisplay Drill-Through Report ToolTips

[ ] show Progress Information After (seconds)
Compatibility

Reduce Excel File Size

Improve Metadata Storage

|:| Refresh Selected Functions and their dependents

Help Reset

Set Mandatory Report Preference

A preference option must be set by each user to pull reports — otherwise an error will occur. If the preference

has already been set, you may leave as is.

1. Loginto the CBIG web application (click here to launch) and go to File > Preferences > Financial Reporting.

Cancel

Save as Default Options
Apply to All Sheets

2. Where it says “User Point of View”, turn the Preview On and click OK:


http://cbig.ais.ucla.edu:19000/workspace/

Preferences

SQR Production Reporting

Financial Reporting

Planning

¢

Oracle BI

Help

Financial Reporting

General Reporting Studio

Default Preview Mode

HTML Preview
() PDF Preview

User Point of View

Setup Members...
Query-Ready Export

Export Mode Export To

(@) Smart View
) Excel Grid
(_) Disabled

(®) New Worksheet
(O) New Warkbook

Word Export

Export As

(7) Image

ocument(.docx)

Connecting to Financial Reports

C-BIG reports can be pulled into Excel sheets to allow formatting changes and manipulation. Reports can also be

Merge Equivalent Prompts

Annotation Print Details...

Thousands Separator
) Comma

Period
Underscore

) Space

Decimal Separator

Period
Underscore
() Space

Date Value Format

Auto Detect =

opened in HTML view or PDF view through the Hyperion Planning web application.

To open a report in Excel via Smart View,

1. Click on the Smart View Ribbon.

2. Click on Panel.

= :
HOME  INSERT  PAGE LAYOUT  FORMULAS DATA  REVIEW
b 1) HE o= = =
- ) Undo | Ba Copy @)@ as ! Help
@ Redo Paste &* Sheet Info
Connections . Refresh | Submit | Options _
- Functions ~ _ D El More ~
ata
Start Edit Data General

3. Inthe Smart View panel, click on Shared Connections.

Cancel

VIEW

SMART VIEW



Smart View 2

Smart View Home o -« »

> Shared Connections

Connections from shared repository

B Private Connections

Locally defined connections and
shortcuts to shared connections

4. Enter your User Name and Password and click Connect:

Connect to Data Source ?

#ﬁ User Authentication Needed.
) Enter correctusername and password to sign on.

User Name: testucla
Password: | T
Cancel Details <<
URL http://cbig.ais.ucla.edu:19000/workspace/SmartViewPr
Provider Oracle Enterprise Performance Management System W

5. Open the Smart View Connection panel and select Reporting and Analysis Framework:

(
—k Smart View 2

Shared Connections o -« »

‘ Reporting and Analysis Frame... | | * -

Oracle® Essbase
Oracle@ Hyperion Planning, Fusion Edition

Reporting and Analysis Framework
L [

raframe

6. Click on the + next to the URL then click the UCLA folder to see listing of report folders.
7. Open reports folders to see reports.
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Smart View 2

Shared Connections fa - »
[

| Reporting and Analysis Framewark

] -

[=- @ hitp://cbig.ais.ucla.edu:19000/raframework/browse/|
#-[F) Broadcast Messages
--[f’jl Crystal Ball Workbooks
--[E] Sample Content
--[EJ Shared Workspace Pages
--[ﬁ] System
=B uaa
=7 01. Analysis Reports
8 £ 01a. P&L by Month, 1 r]
-[&] o1b. P&L by Quarter, 1 Yr
-|&] 02. P&L by Fund Summary, 1 Yr
-J&] 03a. P&L, 5 Yr, w Budget
-J&5] 03b. P&L, 5 ¥r, w Budget
-J&] 03c. P&L, 5 Yr wo Budget
-[E] 04. PRL, 10 ¥r
-J&] 05. Drilldown Org & Fund, 1 Yr
--J&] o6a. Drilldown by Fund, 5 Yr
. Drilldown by Org, 5 ¥r
--J&] 07a. Budget P&L Fund Summary
-|&] 08a. Budget P&L by Quarter
--JE&] 08b. Budget P&L by Month

8. Open report by double clicking on the report name.
9. Review the User Point of View box (not every report has this) and select the desired member for the report

(click Select and choose a member from the dimension hierarchy or type in the exact member name — not
case sensitive).
Users do not have access to the following upper level entities: UCLA

N OPERATIONS, loc_4, etc. They must be changed to a department or org
| o that they have access to. Use the following formats in the User Point of

= View window: dpt_#### or org_##H##.

11



Preview User Point of View (%
This report/book runs for the members on the user Point of View listed
below.
Entity
UCLA OPERATIONS Select...
I 't Document As
L] All Pages Help QK Cancel
[] Split Pages across work — Formatted |
[] Refresh Using Workspace Point of View
Help Cancel

10. Click OK after selections have been made.

11. Next, the Prompt box will appear (if the report has prompts built into it); select one member or multiple
members. To select members, click the member selector icon and move the desired members to the right
panel (you may need to scroll to see the right panel).

Respond to Prompts (%]

Members ~

Available: Fund (1-8 of 8) Selected: Lofl
Find: | Name = [* M M yse wildcards | Rows Per Page: IE
ﬁi | lﬁ l‘i Rows Per Page: IE,

|I"lame |Df_'fau|t | |M
| 20 rund | | O |@.i TotFund

| @J [ core Funds

| = ] TotFundwheserves
| "_J O featl 210
| - B M TotFund

|Tuta| Operating Funds

1 [ fear1_230 |”“'“3'3F'E‘j
EHid chatl_l"rl] |Funds net applicable
- [ sybstitution Variables | v
— 0K Cancel
Help Cancel
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12. Alternatively, enter the fund number in the format “fnd_######" into the prompt box. Be sure to check Edit
Member Names first (if needed).

Respond to Prompts

The following prompt has been defined in the report. You may use the default values shown, or select other members.

Prompt Selection Type Source

Enter FUND/FLIND fnd_19900 Report Re_port:_mb. P&L by Quarter, 1 Yr
CATEGORY (fi Grid; Gridl

format:

fnd_#####):

Edit Member Names

13. Click OK after selections are made.
14. Preview the report. Choose Fully Formatted under the Import Document As option.

Fully Formatted will give you the report as it was built — font formatting, indents,

1
N and borders included! You may change the format of the report after it runs as well.

15. Check All Pages if you have multiple Prompt selections to see separate reports for each selection.
16. Check Split Pages across worksheets if you would like to see each Prompt selection on a different sheet.
17. Click Finish.

Import Workspace Document
FiscalYr: FY17 Entity: UCLA OPERATIONS Sub: TotSub @ E]A

UCLA FY 2016-1

Page: |T0ta| Operating Funds & Res

July August September October November

» General Fund Source 893,033,875 13,132,128 27,444,862 9,646,154 10,133,628

P indirect Cost Distributed Source 93,806,589 537,117 8,346,028 2,155,332 (353,989)

» student Services Fees Source 32,812,145 73,429 14,419 145,363 15,413

¥ University Financial Aid Source 142,764,737 52,896 0 641,134 o

P Other State Funds Source 3,970,838 364,689 410,773 2,847,768 22,959

» Other Source Funds Source 40,376,408 552,101 7,960,393 4,508,859 7,877,500 v
< >
All Pages Import Document As
[] split Pages across worksheets Fully Formatted '

[] Refresh Using Workspace Point of View

Help » Next 4 Back Finish Cancel

13



18. The report will open in Excel, and users can change the formatting to their liking. Once changes have been
made, it can be saved as an Excel file or PDF.

Woo=~gwm = w =

A

UCLA

General Fund Source

Indirect Cost Distributed Source
Student Services Fees Source
University Financial Aid Source
COther State Funds Source

COther Source Funds Source
Contracts and Grants Source

Gifts and Endowments Source
Student Referendum Fees Source
Student Fees - Other Source
Summer Session Funds Source
UCLA Extension Funds Source
Prof. Deg. Supplemental Tuition Source
Self-Supporting Degree Prog. Fees Source
Course Materials Fees Source
Sales and Service Source
Compensation Plan Source
Auxiliaries Source

Reserves Source

Total Revenues

Faculty Ladder

Faculty Temporary

-

B C D E F G H
FY 2016-17 Consolidated Income Statement
UCLA OPERATIONS
Page: Total Operating Funds & Reserves

July August September October Movember December January
893,033,875 13,132,128 27,444,862 9,646,154 10,133,628 7,835,426 (587,207)
99,806,589 537,117 8,346,028 2,155,332 (353,989) 184,892 3,784,896
32,812,145 73,429 14,419 145,363 15,413 3,965,466 590,860
142,764,737 52,896 ] 641,134 0 0 2,018,000
3,970,838 364,689 410,773 2,847,768 22,959 56,000 1,279,546
40,376,408 552,101 7,960,393 4,908,899 7,877,500 2,530,314 3,752,876
153,852,937 97,377,506 151,705,601 47,002,614 44,975,698 35,978,055 50,244,749
67,498,377 33,377,496 27,415,207 24,916,854 17,190,708 24,363,671 28,711,464
3,002,287 762,509 133,960 (1,494} 236,120 336 (1,841)
65,908 22,688 47,295 233,233 651,438 845,919 673,877
52,201,256 (912,701) (8,122) (15,500} (10,354) [994,994) 36,639
21,888,316 10,611,120 9,037,191 2,856,241 7,054,939 7,185,262 8,119,454
21,758,622 7,338,659 (61,475) 918,853 29,043,078 (31,677) [111,332)
26,177,841 19,734,969 549,372 192,333 37,850,775 1,239,935 1,388,405
575,254 169,671 944,009 214,691 3,571,887 492,539 (1,350)
28,744,514 89,970,935 371,023,212 231,284,309 267,368,884 238,150,782 284,386,477
(8,350,316) 99,695,451 99,504,216 98,381,478 94,151,328 101,933,525 88,508,714
32,983,134 17,833,287 27,437,675 42,073,157 34,053,548 21,513,584 48,623,625
241,477 12,824 6,429,286 2,559 61,921 158,453 37,815
1,613,404,200 390,706,774 738,333,903 468,404,476 553,895,481 445,407,489 521,955,667
35,515,456 35,836,001 34,144,235 34,037,830 34,552,573 34,349,350 33,781,133
33,724,196 37,962,763 53,661,373 47,875,149 38,234,596 52,209,367 35,187,466

Reports pulled into Excel may need some formatting such as adjusting the
column widths or row heights, or positioning the text boxes.

Note!
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