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Smart View Training Guide 
This training guide has been created to enable users to take advantage of the data and analysis functions available 
in C-BIG through the Smart View add-in. Should any questions come up during your review of the information, 
please feel free to contact APB’s Hyperion Planning Analyst, Cathy Son at cson@ponet.ucla.edu. 

 

Smart View Overview 
• Microsoft Office add-in for Oracle Hyperion Planning applications 
• Allows users to input data through templates created for C-BIG 
• Provides ad-hoc query capability to users in a familiar Excel environment 
• Allows users to dynamically access the live data and develop their own queries 
• Allows users to pull CBIG reports to manipulate in Excel 

 

Understanding C-BIG and Essbase Databases 
C-BIG is built on Oracle Hyperion Planning software. The Oracle Hyperion Planning application contains 
customized calculations and input forms that users can access through the web application (Workspace) or 
through Excel via Smart View.  

The data for the application is housed in Essbase technology. 
Essbase is a multi-dimensional database (or cube) that allows 
users to slice and dice data and conduct ad hoc analysis. Data 
will appear depending on the intersection of dimension 
members selected (explanations of the dimensions are found 
in the “Dimension Selection” section of this manual). 

Users who have access to the C-BIG application will have access 
to two Essbase databases via Smart View. One database, called 
“Budget”, stores the budget data input by users across campus, 
and the other database, called “CBIGRptg”, contains actuals 
data pulled from QDB on a monthly basis, as well as, budget 
data pulled from the Budget database. CBIGRptg contains an 
extra dimension called “Sub” while the Budget database does 
not. CBIGRptg is the database that users will use to view all 
actual and budget data in one place via Smart View.  

 

  

mailto:cson@ponet.ucla.edu
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Installing Smart View 
To begin, first install Smart View (with the help of your IT team, if needed).  

1. To download, go to the APB C-BIG webpage and click the Download Smart View! link.  
2. Download and install - be sure to right-click the .exe file and select Run as Administrator when 

installing. 
3. Open Excel and verify that the Smart View tab is there. 

 

 

If there are other Excel Add-ins installed, you may need to disable them for 
Smart View to run properly (i.e. Acrobat PDFMaker Office COM Addin). Go 
to File > Options > Add-Ins > Excel Add-ins > Go… and uncheck add-ins you 
would like to disable (see image below). 
 
If Smart View is installed, but does not appear in Excel, make sure Oracle 
Smart View for Office is checked under both Excel Add-ins and COM Add-
ins. 

 

 
Setting Up Smart View Connection 
1. After the installation of Smart View is complete, launch Microsoft Excel. 
2. Select Smart View from the menu. 
3. In the Smart View Ribbon, select Options: 

http://www.apb.ucla.edu/resource-management/c-big
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4. Within the Options window, select Advanced. 
5. In the Shared Connections URL section, copy the entire URL below and paste into the box: 

 https://finbud.it.ucla.edu/workspace/SmartViewProviders 

 

6. Click OK. 
 
 
Connecting to Smart View 
1. Click on the Smart View Ribbon. 
2. Click on Panel. 

 

3. In the Smart View panel, click on Shared Connections. 

https://finbud.it.ucla.edu/workspace/SmartViewProviders


 

6 
 

 

4. Enter your User Name and Password and click Connect: 

 

5. Under Shared Connections, click on the dropdown that says "Select Server to proceed" and click Oracle 
Hyperion Planning, Fusion Edition: 

 

 
 
Setting Smart View User Options 
1. From the Excel ribbon, click the Smart View tab. 
2. From the Smart View tab, click the Options icon: 
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3. Click Member Options and make the following changes as desired: 
- Zoom In Level – Set to Next Level 
- Indentation – Select Subitems, None or Totals 
- Ancestor Position – Select Top or Bottom 

 

 

The following table contains descriptions for what each member option will do: 

Zoom In Level  

     Next Level Display only the next level down in the hierarchy 

     All Levels Display all levels in the hierarchy 

     Bottom Level Display only the lowest level of the hierarchy 

     Sibling Level Display data for the siblings of the selected member 

     Same Level Display data for all members at the same level as the selected member 
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     Same Generation Display data for all members of the same generation as the selected 
member 

     Formulas 
Display data for all members that are defined by the formula of the 
selected member. The formula can be a member equation built into the 
member or a consolidation to the parent. 

Member Name Display  

     Member Name Only Display only the member names (e.g. org_0000, fnd_00000)  

     Member Name and Alias Display member names and descriptions (aliases) 

Indentation  

     None No indentation 

     Subitems Indent only descendants of the selected member 

     Totals Indent only ancestors 

Ancestor Position   

     Top Displays hierarchies from highest to lowest (parents at the top) 

     Bottom Displays hierarchies from lowest to highest (children at the top) 
 

4. Select Data Options and note the options: 
 

• Suppress Rows - Repeated Members – Check the box if you do NOT want to see the same member name 
in each row if there are repeated member names. Leave unchecked if you always want to see member 
names in each row. 

 

Leave the other boxes under Suppress Rows unchecked in order to be able 
to start an ad hoc query. Once a query is started, you can come back and 
choose to suppress rows at that time. 

 

• Replacement - #NoData/Missing Label – Set to #NumericZero 
o This allows for Excel calculations to be used in queries 
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If you are getting an error when attempting to start a Smart View query, 
make sure the Suppress Missing blocks option is unchecked and try again. 
Once the query is started, you can suppress if desired. 

 

5. In the Options, select Formatting and review the options available: 
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The following table contains descriptions for what each member option will do: 

Use Thousands Separator Use a comma or other thousands separator; not available if using Excel Formatting 

Use Cell Styles Apply formatting/cell styles defined in Hyperion Planning by the administrator; this will 
clear any user formatting 

Use Excel Formatting 
Used in place of Smart View formatting. If checked, no cell colors will be applied to the 
ad hoc grid. Overrides Use Thousands Separator, Capture Formatting, and Cell Styles 
options 

     Move Formatting on 
Operations 

Copies parent cell formatting to zoomed in cells; retains the cell format applied even if 
its location changes after an operation (DO NOT CHECK THIS BOX FOR OPTIMAL 
PERFORMANCE) 

Retain Numeric Formatting Retains scaling and decimal place formats when you drill down in dimensions; available 
when using Cell Styles 

Adjust Column width Adjusts column widths automatically after a grid operation 
 

6. Once the Smart View Options have been set to your liking, click the drop down arrow next to the 

 button.  
7. Click Save as Default Options: 

 



 

11 
 

 

Performing Ad Hoc Analysis 
This feature can be used for retrieving data into excel on an ad hoc basis. It can be for one-time use or the Excel 
file can be saved and reused to refresh data at a later time. The following instructions show how to use the Ad 
Hoc features available.  
 

 

If you are experiencing performance issues with Smart View or you would 
like an in-person training, please contact APB’s Hyperion Planning Analyst, 
Cathy Son at cson@ponet.ucla.edu. 

 
 

1. Connect to Oracle Hyperion Planning, Fusion Edition in the Shared Connections Panel:  

 

2. Click the + icon next to UCLA and highlight CBIGRptg: 

 

 
3. Ad hoc analysis should now be showing on the bottom of the panel. Click on Ad hoc analysis and the 

beginning of a new grid will appear on the Excel sheet: 

mailto:cson@ponet.ucla.edu
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#No Access may appear because the dimensions have not been specified and are pointing to the top-most level. 

 

As documented under the Data Options section, if you have Suppress 
Missing Data or zeros, or Suppress Missing Blocks checked, then a new grid 
will not show and you will get the error message below.  
 
Go to Options and uncheck the suppression options. Then click Ad hoc 
analysis again in the connections panel. 
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4. Once you have made a connection to Smart View, you will be able to connect using the “Recently Used” 
connections. Simply click the connection in the connection panel and you will be prompted to enter your 
User Name and Password to connect. This will bypass the “Shared Connections” process.  

 

5. If you are opening an Excel file that already has a Smart View grid on it, connect using the method above 
and make sure you select Reuse sheet contents and POV when prompted: 
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Clear sheet contents and POV will bring you to a new Smart View grid: 

 
 

Dimensions Overview 
There are 9 dimensions available for selection in the CBIGRptg database. They must be present and defined in all 
grids in order to retrieve data. The brief description of the dimensions are as follows: 

• Object: contains Revenue, Expenditures, Carryforward, etc. – goes down to the object code level for 
Expenditures 

• Period: contains “YearTotal”, quarters, or months 
• Scenario: houses a member called “Current” and another called “YTD”. Using Current will give you data 

for the specified month in the Period dimension. Using YTD (year-to-date) will give you data from July to 
the specified month. Using YearTotal using either Current or YTD will give you the same results (amount 
for total year). 

• Version: contains “Working”, “Working2”, or “Final” versions – please use Final for viewing Actuals. 
Working or Working2 is used to view Budget data that has not been finalized.  

• Component: contains members such as “Budget”, “Actual”, “PermBud”, etc. (found in the Misc. 
Classifications member) 

• FiscalYr: contains years 2004 to current budget year  
• Sub: contains all subs (e.g. sub_01) 
• Entity: houses all the orgs, divs, sdvs, and dpts – goes down to the account level (e.g. dpt_####) 
• Fund: Stores fund categories and goes down to the fund level (e.g. fnd_19900) 
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Dimension Layout 
Dimensions will be located in the Rows, Columns, or Point of View (POV). The POV is located in the POV menu 
box), and the members selected in these dimensions will apply to the entire grid. There must always be at least 
one dimension in the Rows and one in the Columns. 

 

 

 

To clear the blue and gray colors from the ad hoc grid, go to Smart View tab 
> Options > Formatting, then click the Use Excel Formatting option. Click 
Save as Default Options instead of clicking OK. Create a new sheet in Excel 
and connect to create a new ad hoc grid.  

 

The location of the dimensions can be moved where desired. To move dimensions from the POV to the row or 
columns, left click, hold, and drag the dimension as shown below: 
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To move a dimension to the POV, click the dimension and use the Pivot button to “swap” dimensions between 
columns and rows or between the grid and POV. You must have at least two dimensions in rows or columns 
before you are able to pivot a dimension out. 

 

We can also simply delete a dimension from the rows or columns and hit Refresh to send it to the POV. 
Alternatively, we can select a dimension member and click Pivot > Pivot to POV.  

A row or column can also be inserted into the Excel sheet and a dimension member from the POV can be typed 
in. Click Refresh and that dimension will now be in the grid and not the POV. 
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Dimension Selection 
Now that you understand the dimensions and the layout of the ad hoc grid, it’s time to select members within 
the dimensions and see some data! 

Please note that all dimensions must specified for data to show (e.g. Select Total Sub for the Sub dimension, 
define the Fiscal Year). There are several ways to select dimension members for the Rows, Columns, and POV: 

 Select members in the POV by using the POV tool 
 Type in the exact member name in the cell or POV field containing the dimension name 
 Click on the dimension name and then click Member Selection to select from the dimension hierarchy 
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 Drill in and out of a dimension using the Zoom In button (or double click the cell) and Zoom Out button 
until you find the desired member(s) within a dimension. Use Keep Only and Remove Only to simplify 
your grid. 

 

 

Once you are familiar with the hierarchy and names of the members, typing 
member names into cells will simplify your ad hoc experience tremendously. 
Always hit Enter or click out of the cell after typing in a member/alias name 
and then click Refresh to view correct data for that intersection of members, 
otherwise an error will appear. 

 

Planning Ad Hoc Ribbon 
The Planning Ad Hoc ribbon is available once a user connects to the CBIGRptg database; it provides features and 
functions available for ad hoc analysis. This section will review the buttons users will most frequently use. 

 

Zoom In & Out of Dimensions 
 

• Zoom In: Allows you to drill down into lower members within the selected dimension hierarchy 
• Zoom Out: Allows you to drill up one level higher within the selected dimension hierarchy         

 
Users have options to Zoom In at different levels: 

  

 
Keep and Remove Members 

 
• Keep Only - Allows you to keep only specified selected member(s)  
• Remove Only - Allows you to remove only specified selected member(s)  

 
This only works when selecting members from one dimension at a time. 
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Refresh 
The grid will need to be refreshed when a change has been made to the ad hoc grid. The latest C-BIG data will be 
pulled with every Refresh. Click Refresh in the Essbase tab when you perform the following actions: 

• Change dimension members 
• Change dimension layout 
• Change any Smart View options  

 
Change Alias 
All members have an actual member name and alias (description). To toggle between the member name and 
alias, click the Change Alias button and choose between None or Default. 

• None – displays the member names (shorthand names you can type into the ad hoc grid to retrieve the 
member) 

• Default – displays the alias (full descriptions of member names) 
• OCAT – ignore this option 

 
POV Menu 
To select members for the dimensions in the POV menu, 

1. Click on the POV icon in the Planning Ad Hoc tab if it is not shown already: 

 

2. Click on the ellipsis “…” in the drop-down to select a member from the dimension: 
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3. The Member Selection window will appear: 
4. Find and check the box next to the member(s) that you want to use and click on the right-pointing arrow 

to move it to right-hand (selection pane) section. Click OK. 

 

5. Remove anything from the right-hand section you do not want by highlighting the member and clicking 
the left-hand arrow (you can leave more than one member in the right-hand section). Click OK.  

6. Select the member you selected from the drop down menu in the POV menu. If you chose more than 
one member for a dimension, both options will appear in the drop down menu, but you can only choose 
one to apply to the grid. 
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7. Click Refresh in the POV menu to see the data with the newly selected member. 

As mentioned earlier, we can also drag and drop POV members from the POV menu to the grid.  

8. Click and hold on the drop down arrow next to the dimension name and drag it from the POV menu to 
the rows or columns of the grid. 

 

 

A dimension can be moved back to the POV menu by clicking on the dimension name and then clicking on Pivot 
To POV: 
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Cascade 

 
Cascade allows you to create separate grids for a selected POV member in the grid into a current workbook, 
new workbook or different workbook. The grids are populated in separate sheets of the Excel document. Sheets 
will be named with the member name used to cascade. 

 
Excel limits sheet names to only 31 characters. 

 
 Place the dimension that you want to cascade in the POV (if it’s not already there). 
 Click Cascade and select Same, New or Different Workbook. 
 Select the dimension desired (drop-down menu located at the top left corner). 
 Select all members in the dimension you wish to Cascade and click OK (for best results, do not click too 

many at a time). 
 After Excel processes the request, new sheets will be created for each member selected (depending on 

how many members were selected, it may take a few moment for Excel to complete the action). 
 

 
Excel Formulas and Conditional Formatting 

 
You can insert formulas and format like you normally would in any other spreadsheet. Common examples include: 
bold, cell color, fonts, cell borders, and math functions. 

Depending on your Formatting settings under Options, Smart View will preserve all formatting when you save 
and reopen the sheet.  
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Ad Hoc Reference Guide 
Please refer to the chart below to understand when certain dimension members should be used: 

Member Name Member Alias Dimension When to use the member 

YTD YTD Scenario 

Year-To-Date. Use this member to pull data from July to the 
specified Period/Month. For example, choosing YTD for Scenario 
and Dec for the Period will query data from July to Dec for the 
specified Fiscal Year. You can also use YTD with YearTotal as the 
Period to view data for the entire year.  

Current  Current Scenario 
Use the Current member to pull data for one specified month or 
YearTotal. For example, choosing Current for Scenario and Dec for 
Period will query data for December only.  

ApprovedBud Budget Component 
ApprovedBud, or Budget, is where users input their budget plans 
during budget season. Does not necessarily mean that the budget 
has been approved.  

Forecast Forecast 
(Jan:Jun) Component 

Forecast was introduced in the FY 2018-19 budget season. The 
values entered in Forecast indicate the forecast for the later half of 
the specified year. Data for Forecast is stored in June, but is 
actually the sum of January to June.  

Working Working Version 
The Working Version is where users first enter their Budget and 
Forecast data. The intersection of the Working Version and the 
Actual Component houses actuals with Summer adjustments  

Working2 Working 2 Version 

Working 2 is where users revise their initial/Working Budget data. 
The Hyperion administrator copies the data from Working to 
Working 2 before revisions can be made (typically after year-end). 
If departments do not revise their budgets, Working and Working 
2 will contain the same data. 

Final Final Version 

Data is moved from Working 2 to Final by the Hyperion 
administrator once the Budget is final and no changes will be 
made to the Budget data. Actual data, as shown in the ledger, will 
reside in Final.  
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Troubleshooting 
In this section, common errors in Smart View have been addressed. Before addressing any of the issues found 
below, please ensure that you have installed the latest version of Smart View. The latest version can always be 
found on the APB C-BIG webpage under the Download Smart View section. You may or may not need to 
uninstall a prior version before installing a new Smart View version. Please do not hesitate to contact the 
Hyperion Planning Analyst, Cathy Son Kim (cson@ponet.ucla.edu), if assistance is needed. 

 

Timeout Error Message 
If you receive an error message that looks like the image below, please follow these instructions. 

 

Text: The request timed out. Contact your Smart View client system administrator to extend your Windows 
Internet Explorer time out settings (ReceiveTimeout, KeepAliveTimeout, and ServerInfoTimeout).  

 

To address the error, 

1. Go to Run (right click your computer’s Start menu to find it) and type "regedit": 
  

 

  
2. Click OK. 
3. In the Registry Editor, follow this folder path: 

• HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Internet Settings 

https://www.apb.ucla.edu/resource-management/c-big
mailto:cson@ponet.ucla.edu
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• Note: Your IT dept can change settings in the HKEY_CURRENT_USER folder, but changes will NOT 
save. You will have to make these changes yourself.  

 

  
4. Once you are in the Internet Settings folder, right click in the right pane and click the DWORD option: 

 

5. Type three decimal DWORD registry values (one at a time): 
• ReceiveTimeout 
• KeepAliveTimeout 
• ServerInfoTimeout 

 
6. Once all three have been created, right click and click Modify. 
7. For each value, click the Decimal option under Base and type in the values accordingly: 
• ReceiveTimeout=480000 
• KeepAliveTimeout=180000 
• ServerInfoTimeout=180000 
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8. Verify that you have input all information correctly.  
9. The same values need to be installed in the registry key by your IT department (if you don’t have the 

access to do so): 
• HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Internet Settings 

  
Once both locations in the Windows registry are updated, restart Excel and Smart View will no longer have a 
timeout issue. 

 

Smart View Tab Disappears 
If the Smart View tab suddenly disappears once Excel is opened,  

1. Go to File > Options > Add-Ins. 
2. In the Manage section, go to Excel Add-ins and COM Add-ins (one at a time) and check that the Oracle 

Smart View for Office option is checked. Also make sure that it is not listed in Disabled Items. 
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If the problem persists and the Smart View tab disappears every time Excel is opened, please follow the steps 
below: 

1. Go to Run (right click your computer’s Start menu to find it) and type "regedit": 

 

2. Click OK. 
3. In the Registry Editor, follow this folder path: 

• In HKEY_CURRENT_USER/Software/Microsoft/Office/Excel/Addins/Hyperion.CommonAddin 
4. Right click LoadBehavior and click Modify. 
5. Set the value to "3" (Hexadecimal) and click OK: 

 

6. Re-open Excel and test.  
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Failed to Open Message Log File Error 
If you receive the following message when trying to save your Options, please create a log file by following the 
steps below: 

 

1. In Options > Advanced, check Route Messages to File option and click on the elipses icon to search for a file 
location: 
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2. At a folder/location of your choice, right-click and select New > Text Document. 
 

 

3. Name your document “SmartViewLog.log” and select Open. 
4. Uncheck the Route Messages to File option and click OK > Save as Default Options: 
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